Sunday, February 14

4 Simple Steps to free North American phone calls with Google Voice, Gizmo5, and Empathy

Image representing Gizmo5 as depicted in Crunc...
If you've got Google Voice and you have wondered, "How can I make free phone calls using this thing?", then you've no doubt seen the many articles telling you how to use Gizmo to forward to Skype.  The problem in the past has been the limited call time.

Image representing Google Voice as depicted in...Well, I just made a 15 minute outbound call using Google Voice+Gizmo+Empathy, obviously surpassing what has been a 3 minute limit in the past.  I am not sure if the limit has been lifted, increased, or if it was something to do with forwarding Gizmo to Skype, but when I use Empathy as a softphone connection to Google Voice it is working great.  Perhaps its a feature of the Gizmo5 aquisition by Google.

The important difference here is setting up a SIP phone rather than using call forwarding to Skype.  I had it set up at one point but it always seemed like a shaky solution.  While I have not been a huge fan of the Ubuntu decision to go to Empathy from the stalwart Pidgin, this seems to be the first realization(at least for me) that it will be a better long term solution.

Here's how to set it up.
1. Sign up for a Gizmo5 account at  Sorry, if you don't already have a Gizmo5 account you are out of luck as they are not accepting new users until they relaunch.
2. When your account has been set up you will need to set up Empathy(or your softphone of choice).  On the Account Overview page, make a note of your SIP number.  Then use the SIP settings for configuring your SIP account.  An important note, your user id is your SIP number, NOT 17471115555.  Do not copy and paste it because it won't work.  Below is an example of what the SIP setup should look like in Empathy.

At this point it probably wouldn't be a bad idea to make a phone call to this number to make sure it works correctly.

3. Set up Google Voice

4. Once finished, you will have to verify the phone number.  Make sure you enable the dial pad on your softphone in order to enter the verification number.

And that's it.  4 simple steps to free phone calls to the US and Canada.
Reblog this post [with Zemanta]

Wednesday, February 10

Linksys WRT310N is a FAIL

I bought this router a couple months ago and, for the most part it seems to do it's job.  It's nothing fancy, but I have had a very strange issue for a while now where I simply end up going to the wrong page.  Facebook ends up on Myspace.  Endless SSL issues where the site I am trying to hit is not the SSL certificate I get.

My first thought was that someone was messing with my router.  It's happened before even though it's locked down to mac addresses, the radio is off, and the router is secured.  After searching through the logs, confident that no one was in there maliciously, I headed to the next likely culprit, my ISP.  Where I live in the country, broadband internet choices are limited.  I chose DSLExtreme... funny name, but their service is good and their support staff not only speaks *good* English, they are actually knowledgeable and they don't just mindlessly follow a flowchart.  However, the fact that they are not a Verizon or AT&T sometimes makes me wonder if there may be wonkiness that the big guys have already worked out.  Still, after talking to the techs there for about a half hour, we found nothing.  They suggested I clear the DNS cache on my router and my computer.  I did that and it seemed to work for a while, but the problem came back not long after.

In retrospect, now that I know what the issue is, it's pretty obvious why it worked immediately after clearing the cache, but the problem cropped up again so quickly that I actually thought it was not fixed.  So I dealt with the issue for a while until this morning, when I actually got so fed up with it that I went searching.  Turns out there's a whole community of people with the same problems as me.  The user forum for the 310n has a thread started sometime last September which points to the issue that also occurs on the 160N

The worst part about it is, Linksys is not fixing the issue.  Multiple people have gotten the "Sorry, we've never heard of this issue before." ... FAIL!  In an interconnected society like we have now with user forums, social networking and so on, you can't tell more than one person that or we all know about how bad you fail.

The workaround works.  I might even venture into the DD-WRT world, which has an experimental version of their firmware that is supposed to work.  Still, this seems like a pretty obvious issue that needs to be fixed and not with a workaround like editing network settings on the computers.